preguntar acerca de rvm

30
réponses

comment faire pour résoudre «ruby installation est manquant psy» erreur?

J'ai utilisé rvm pour installer ruby 1.9.3. même s'il a été installé avec succès, il s'est plaint de libyaml. et maintenant, chaque fois que je veux installer une gemme (disons rails), cet avertissement apparaît: It seems your ruby installation is …
demandé sur 1970-01-01 00:33:32
5
réponses

Bibliothèque non chargée: / opt / local / lib / libssl.1.0.0.dylib (LoadError)

Je viens de découvrir que je ne peux plus gem push … et quelques recherches m'ont amené à mettre à jour mes certificats SSL RVM. , j'ai couru rvm osx-ssl-certs status all, mais qui m'a donné: /Users/davesag/.rvm/rubies/ruby-2.0.0-p195/lib/ruby/site …
demandé sur 1970-01-01 00:33:33
10
réponses

RVM ne fonctionne pas sur SSH

RVM ne fonctionne pas sur SSH. Sur la ligne de commande: leifg@host:~$ which ruby /usr/local/rvm/rubies/ruby-1.9.2-p290/bin/ruby Connecté via SSH: local:~$ ssh leifg@server 'which ruby' /usr/bin/ruby J'utilise Ubuntu 11.04. Comment puis-je …
demandé sur 1970-01-01 00:33:31
6
réponses

RVM et Jenkins setup

Je suis nouveau à Jenkins CI. J'installe RVM dans mon Jenkins distant et quand j'exécute sous shell. #!/bin/bash -x source ~/.bashrc rvm use 1.9.3@rails-3.2.3 j'obtiens les erreurs suivantes. + source /var/lib/jenkins/.bashrc ++ PATH=/usr/loca …
demandé sur 1970-01-01 00:33:32
12
réponses

Bundle ne peut pas installer RMagick gem sur Mac OSX 10.7

J'ai installé ImageMagick avec le script D'installation D'ImageMagick https://github.com/maddox/magick-installer ... …
demandé sur 1970-01-01 00:33:32
10
réponses

Comment puis-je supprimer RVM (Ruby Version Manager) de mon système?

Comment puis-je supprimer RVM (Ruby Version Manager) de mon système? ... …
demandé sur 1970-01-01 00:33:30
13
réponses

Comment puis-je changer ma version Ruby en utilisant RVM?

Je ne peux pas changer la version Ruby actuelle: ➜ ~ rvm list rvm rubies ruby-1.9.2-p290 [ x86_64 ] ruby-1.9.3-p0 [ x86_64 ] ➜ ~ rvm use ruby-1.9.3-p0 RVM is not a function, selecting rubies with 'rvm use ...' will not work. …
demandé sur 1970-01-01 00:33:31
7
réponses

Attention RVM! Le chemin n’est pas correctement configuré

je viens d'installer rvm sur mon mac, mais je reçois cet avertissement sur global commands Attention! Le chemin n'est pas correctement configuré, '/usr/local/rvm/gems/ruby-1.9.3-p194/bin' n'est pas à la première place, habituellement …
demandé sur 1970-01-01 00:33:34
9
réponses

RVM installé par Ruby ne fonctionne pas?

j'ai installé RVM en utilisant l'instruction simple mentionnée sur le site web RVM (en utilisant git). puis j'ai installé Ruby version 1.9.2 et 1.8.7 en utilisant: rvm install 1.9.2 rvm install 1.8.7 cependant, je ne trouve pa …
demandé sur 1970-01-01 00:33:31
4
réponses

Comment résoudre le répertoire «/usr/bin/env ruby exécutable crochets: Aucun fichier ou répertoire»?

je viens de déployer jekyll dans un vps, et config git post-recevoir de l'hameçon. Quand je pousse la mise à jour de blog à vps de mon ordinateur portable, je cours dans cette erreur: remote: /usr/bin/env: ruby_executable_hooks: No such file o …
demandé sur 1970-01-01 00:33:34