Questions sur easy-install

30
réponses

Comment installer pip sous Windows?

pip est un remplacement pour easy_install . Mais dois-je installer pip en utilisant easy_install sur Windows? Est-il un meilleur moyen?
demandé sur 2011-01-20 21:08:59
9
réponses

Comment installer lxml sur Ubuntu

j'ai de la difficulté à installer lxml avec easy_install sur Ubuntu 11. Quand je tape $ easy_install lxml , ... part aucune pierre non retournée, j'ai réussi à faire sudo apt-get install libxml2-dev , mais cela ne change rien.
demandé sur 2011-06-28 14:08:21
15
réponses

Trouver tous les paquets installés avec une installation facile/pip?

y a-t-il un moyen de trouver tous les paquets PyPI de Python qui ont été installés avec easy_install ou pip? Je veux dire, en excluant tout ce qui a été/est installé avec les outils de distributions (dans ce cas apt-get sur Debian).
demandé sur 2011-07-06 22:00:02
2
réponses

Quelle est la différence entre dist-packages et site-packages?

je suis un peu contrarié par le processus d'installation du paquet python. Plus précisément, quelle est la différence entre les paquets installés dans le répertoire dist-packages et le répertoire site-packages?
demandé sur 2012-02-22 05:29:08
3
réponses

Puis-je utiliser` pip 'au lieu de' easy install` pour ' python setup.py installer la résolution de dépendances?

python setup.py install installera automatiquement les paquets énumérés dans requires=[] en utilisant easy_install . Comment faire pour qu'il utilise pip à la place?
demandé sur 2010-01-18 18:40:17
16
réponses

ImportError: pas de module nommé PIL

j'utilise cette commande dans le shell pour installer PIL: easy_install PIL puis j'exécute python et j ... line 1, in <module> ImportError: No module named PIL je n'ai jamais eu de problème, qu'en pensez-vous?
demandé sur 2012-01-14 21:24:27
24
réponses

problème pip installer presque n'importe quelle bibliothèque

j'ai du mal à utiliser pip pour installer presque n'importe quoi. Je suis nouveau dans le codage, alors j'ai pensé que ... mentaires sur la façon dont je peux faire fonctionner pip ou quelque chose pour contourner le problème en attendant.
demandé sur 2013-05-04 08:29:21
17
réponses

ImportError: aucun module nommé Crypto.Chiffrement

quand j'essaie de courir app.py (Python 3.3, Phycrypto 2.6) mon virtualenv continue de retourner l'erreur listée ci-de ... en n'a fonctionné. vous pouvez voir ce que les fichiers sont comme pour PyCrypto ci-dessous:
demandé sur 2013-10-28 00:39:10
3
réponses

Installer version avec installation facile

j'essaie d'installer lxml . J'ai regardé le site web, et la version 2.2.8 m'a semblé raisonnable , mais quand j'ai fait ... corriger cela et comment puis-je forcer easy_install à installer une version particulière? (Mac os x 10.6)
demandé sur 2010-09-30 21:05:03
4
réponses

Le problème avec l'installation de PIL en utilisant virtualenv ou buildout

quand j'installe PIL en utilisant easy_install ou buildout il s'installe de telle manière que je dois faire "importer ... c buildbot, il utilise des œufs. comment installer correctement PIL, en utilisant easy_install ou buildout?
demandé sur 2010-03-21 03:19:07
4
réponses

virtualenv, mysql-python, pip: quelqu'un sait comment? [dupliquer]

cette question a déjà une réponse ici: pip install mysql-python échoue avec Envir ... rceforge ou me donne une erreur très similaire. personne Ne sait comment contourner ce dans un virtualenv?
demandé sur 2009-10-03 00:33:53
7
réponses

Pourquoi Python easy install ne fonctionne-t-il pas sur mon Mac?

j'ai un Mac qui exécute Python 2.6. Quand j'essaie d'utiliser easy_install je reçois ce message: /usr/bin/eas ... emandais comment je pouvais corriger cela, ou restaurer les paramètres par défaut de Python ou easy_install sur Mac.
demandé sur 2011-05-16 04:32:22
3
réponses

pip ignore les liens de dépendance dans setup.py

j'ai dependency_links dans mon setup.py: ... dependency_links = ['http://github.com/robot-republic/python-s3/ta ... bien. Peut-être qu'il y a une autre méthode pour mettre en place git repo comme requis pour setup.py Je ne sais pas.
demandé sur 2012-09-20 22:17:42
1
réponses

Comment puis-je pointer l'installation facile à vcvarsall.chauve-souris?

J'ai déjà MSVC++ 2010 Express installé, et mon vcvarsall.le fichier bat est à C:\Program Files\Microsoft Visual Studi ... _install-fhraep\dulwich-0.7.1\egg-dist-tmp-qozily error: Setup script exited with error: Unable to find vcvarsall.bat
demandé sur 2011-07-01 22:17:03
2
réponses

arrêt setup.py de l'installation en tant qu'oeuf

Comment puis-je arrêter setup.py de l'installation d'un paquet comme un oeuf? Ou mieux encore, comment dois-je easy_insta ... brute force façon de faire: sudo easy_install -m boto cd path/to/boto-xyz.egg sudo mv boto .. sudo rm -rf boto-xyz.egg
demandé sur 2011-06-10 05:13:48
3
réponses

Déterminer la version de facile installer / setuptools

j'essaie d'installer couchapp, qui utilise easy_install - et qui est assez explicite dans la déclaration d'une version pa ... loppeur Python, donc je suppose que c'est une question simple. Cependant, je n'ai rien trouvé via Google ou ici sur SOF.
demandé sur 2009-12-24 07:21:51
3
réponses

pyzmq manquant lors de l'exécution de l'ordinateur portable ipython

je peux lancer iPython, mais quand j'essaie d'initier un notebook j'obtiens l'erreur suivante: ~ ipython notebook ... rtError("%s requires pyzmq >= %s"%(required_by, minimum_version)) ImportError: IPython.html requires pyzmq >= 2.1.11
demandé sur 2014-07-28 16:38:40
7
réponses

Comment installer easy install en python 2.7.1 sur Windows 7

j'ai installé Python 2.7.1 sur Windows 7, mais je ne peux pas installer easy_install. S'il vous plaît aider moi.
demandé sur 2011-02-08 09:29:07
2
réponses

pip cassé après la mise à niveau

j'ai fait pip install-U easyinstall, puis pip install-U pip pour mettre à jour mon pip. Cependant, je reçois cette err ... 3a66:/# pip bash: /usr/bin/pip: No such file or directory C'est sur une ubuntu 12.04 dans une image docker.
demandé sur 2014-10-10 19:23:55
2
réponses

Easy install: ImportError: point D'entrée ('console scripts',' easy install') non trouvé

j'ai utilisé easy_install pour installer pip, pip pour installer django, virtualenv, et virtualenvwrapper. j'ai juste ret ... easy_install') not found après une bonne soirée de chasse, je suis perplexe quant à la façon de résoudre ce problème.
demandé sur 2012-10-12 16:10:43
9
réponses

Pip (ou setuptools, distribute etc...) peut-il lister la licence utilisée par chaque paquet installé?

j'essaie d'auditer un projet Python avec un grand nombre de dépendances et bien que je puisse vérifier manuellement les t ... ze). est-ce que quelqu'un a des pointeurs vers un outil pour lister les métadonnées de licence pour Des paquets Python?
demandé sur 2013-09-30 07:27:06
9
réponses

Comment installer virtualenv sans utiliser sudo?

j'ai easy_install et pip . j'ai eu beaucoup d'erreurs sur mon Linux Mint 12 , je viens de le réinstaller ... env sans utiliser sudo ? Puis-je utiliser pip ou easy_install sans utiliser sudo ? Ou est-il un autre moyen?
demandé sur 2012-02-19 15:47:58
5
réponses

facile à installer lxml sur Python 2.7 sur Windows

j'utilise python 2.7 sur Windows. Comment se fait-il que l'erreur suivante se produise lorsque j'essaie d'installer [l ... ' extension error: Unable to find vcvarsall.bat [1]: http://lxml.de/ [2]: http://pypi.python.org/pypi/setuptools
demandé sur 2012-02-26 18:41:24
2
réponses

Comment désinstaller un module Python ("egg") que j'ai installé avec easy install?

j'ai installé quelques modules Python en utilisant easy_install. Comment puis-je le désinstaller? Je ne pouvais pas voir une option de désinstallation listée dans easy_install --help.
demandé sur 2010-12-05 16:13:33
3
réponses

Installer psycopg2 (postgresql) dans virtualenv sous windows

j'ai installé psycopg2 dans virtualenv en utilisant easy_install psycopg2 . Je n'ai pas vu d'erreurs et on dirait que l ... ne 7, in <module> File "build\bdist.win32\egg\psycopg2\_psycopg.py", line 6, in __bootstrap__ Merci.
demandé sur 2010-06-13 07:42:02
2
réponses

setup.py: restreindre la version autorisée de l'interpréteur python

j'ai une bibliothèque python. Malheureusement, je ne l'ai pas encore mis à jour pour travailler avec python 3. dans son s ... is qui se contenterait d'une solution qui ne fonctionne qu'en pip (et j'espère ne cause pas de easy_install à étouffer).
demandé sur 2012-12-18 05:19:27
2
réponses

Comment puis-je faire installer par setuptools un paquet depuis une autre source qui est également disponible sur pypi avec le même numéro de version?

c'est une question similaire à Comment puis-je faire installer par setuptools un paquet qui n'est pas sur PyPI? ma ... seul dans la liste, qui n'est pas encore installé. S'il manque un autre paquet, il le téléchargera à partir de pypi.
demandé sur 2012-06-14 15:28:57
4
réponses

comment exécuter easy install en utilisant une version particulière de python

j'ai 3 versions de python, je veux easy_install Orange en utilisant la seconde version. Comment puis-je faire cela? Inut ... s de Python, vous pouvez lancer Python avec-easy_install pour exécuter la commande easy_install de cette version Python"
demandé sur 2011-07-07 17:54:21
11
réponses

échec de pip / easy install: échec de la création du processus

après avoir suivi cet article: comment installer pip sous Windows? sur mon système Windows utilisant Enthought Can ... o create process j'ai essayé de re-installer setuptools, en lançant cmd prompt comme admin sans aucun effet.
demandé sur 2013-06-29 00:38:53
5
réponses

Installer Facile Installer... pour se rendre à l'installation de lxml

j'ai pris en charge le fait que ElementTree ne va pas faire ce que je veux qu'il fasse. J'ai vérifié la documentation pou ... e gcc-4.0: No such file or directory error: Setup script exited with error: command 'gcc-4.0' failed with exit status 1
demandé sur 2010-03-03 03:31:19