Comment dois-je traiter le "paquet 'xxx' " n'est pas disponible (pour la version X de R).Y. z) " avertissement?

j'ai essayé d'installer un paquet, en utilisant

install.packages("foobarbaz")

mais a reçu l'avertissement

Warning message:
package 'foobarbaz' is not available (for R version x.y.z)

pourquoi R ne pense pas que le paquet est disponible?

Voir aussi ces questions se référant à des cas spécifiques de ce problème:

mon paquet ne fonctionne pas pour R 2.15.2

le paquet "Rbbg" n'est pas disponible (pour la version R 2.15.2)

paquet non disponible (pour la version R 2.15.2)

paquet doMC non disponible pour la version R 3.0.0 avertissement en installation.colis

dépendance "Rglpk’ n'est pas disponible pour le paquet" fPortfolio’

Que faire lorsqu'un paquet n'est pas disponible pour notre version R?

le paquet bigvis pour R n'est-il pas disponible pour la version 3.0.1 de R?

le paquet 'syncwave’ / ’ mvcwt' n'est pas disponible (pour la version R 3.0.2)

le paquet " diamonds’ n'est pas disponible (pour la version R 3.0.0)

le paquet plyr pour R n'est-il pas disponible pour la version 3.0.2 de R?

https://stackoverflow.com/questions/21580661/installing-predictabel-package-on-r-2-15-2

paquet bigmemory ne s'installant pas sur R 64 3.0.2

paquet "makeR" n'est pas disponible (pour la version 3.0.2)

paquet " RTN’ n'est pas disponible (pour la version R 3.0.1)

difficulté à installer geoR colis

le paquet " twitterR’ n'est pas disponible (pour la version R 3.1.0)

comment installer ' Rcpp, package? J'ai eu "le paquet n'est pas disponible"

le paquet " dataset’ n'est pas disponible (pour la version R 3.1.1)

"le paquet" rhipe’ n'est pas disponible (pour la version r 3.1.2)"

https://stackoverflow.com/questions/31439092/package-dplyr-is-not-available-for-r-version-3-1-1

397
demandé sur Community 2014-09-08 14:11:07
la source

15 ответов

1. Vous ne pouvez pas épeler

la première chose à tester est avez-vous épelé le nom du paquet correctement? les noms de paquets sont sensibles à la casse dans R.


2. Vous n'avez pas regardé dans le bon dépôt

ensuite, vous devriez vérifier si le paquet est disponible. Type

setRepositories()

Voir aussi ?setRepositories .

pour voir dans quels dépôts R cherchera votre paquet, et optionnellement sélectionnez quelques dépôts supplémentaires. À tout le moins, vous voudrez normalement CRAN pour être sélectionné, et CRAN (extras) si vous utilisez Windows, et le Bioc* référentiels si vous n'avez aucune [gen/s/metabol/transcription]omique analyses biologiques.

pour changer en permanence ceci, ajoutez une ligne comme setRepositories(ind = c(1:6, 8)) à votre fichier Rprofile.site .


3. Le paquet n'est pas dans les dépôts que vous avez sélectionnés

retourner tous les paquets disponibles en utilisant

ap <- available.packages()

Voir aussi noms des paquets disponibles de R , ?disponible.les paquets .

Puisque c'est une matrice de grande taille, vous pouvez utiliser le visualiseur de données pour l'examiner. Alternativement, vous pouvez rapidement vérifier si le paquet est disponible en testant les noms de lignes.

View(ap)
"foobarbaz" %in% rownames(ap)

sinon, la liste des colis disponibles peut être consultée dans un navigateur pour CRAN , CRAN (extras) , Bioconducteur , R-forge , RForge , et github .

un autre message d'avertissement que vous pouvez recevoir lorsque vous interagissez avec les miroirs CRAN est:

Warning: unable to access index for repository

qui peut indiquer que le dépôt de CRAN sélectionné n'est actuellement pas disponible. Vous pouvez sélectionner un miroir différent avec chooseCRANmirror() et essayer l'installation à nouveau.


il y a plusieurs raisons pour lesquelles un paquet peut ne pas être disponible.


4. Vous ne voulez pas d'un paquet

peut-être que vous ne voulez pas vraiment un paquet. Il est courant d'être confus sur la différence entre un paquet et une bibliothèque , ou un paquet et un ensemble de données.

un colis est une collection standardisée de matériaux prolongeant R, p.ex. en fournissant du code, des données ou de la documentation. Une bibliothèque est un lieu (répertoire) où R sait trouver des paquets qu'il peut utiliser

pour voir les données disponibles, tapez

data()

5. R ou Bioconducteur est périmé

il peut dépendre d'une version plus récente de R (ou d'un des paquets qu'il importe/dépend de does). Regardez

ap["foobarbaz", "Depends"]

et envisagez de mettre à jour votre installation pour la version actuelle. Sur Windows, cela se fait le plus facilement via le paquet installr .

library(installr)
updateR()

(bien sûr, vous pouvez avoir besoin de install.packages("installr") d'abord.)

de manière équivalente pour les paquets Bioconducteurs, vous devrez peut-être mettre à jour votre installation Bioconducteur.

source("http://bioconductor.org/biocLite.R")
biocLite("BiocUpgrade")

6. Le paquet est périmé

Elle peut avoir été archivée (si elle n'est plus entretenue et ne satisfait plus aux épreuves R CMD check ).

dans ce cas, vous pouvez charger une ancienne version du paquet en utilisant install_version()

library(remotes)
install_version("foobarbaz", "0.1.2")

une alternative est d'installer à partir du miroir GitHub CRAN.

library(remotes)
install_github("cran/foobarbaz")

7. Il est pas de Windows/OS X / Linux binaire

il ne peut pas avoir un Windows binaire en raison de la nécessité de logiciels supplémentaires que CRAN n'a pas. De plus, certains paquets ne sont disponibles que via les sources pour certaines ou toutes les plateformes. Dans ce cas, il peut y avoir une version dans le dépôt CRAN (extras) (voir setRepositories ci-dessus).

si le paquet nécessite de compiler du code (par exemple C, C++, FORTRAN) alors sous Windows installer Rtools ou sur OS X installer le developer tools accompagnant XCode, et installer la version source du paquet via:

install.packages("foobarbaz", type = "source")

# Or equivalently, for Bioconductor packages:
source("http://bioconductor.org/biocLite.R")
biocLite("foobarbaz", type = "source")

sur CRAN, vous pouvez dire si vous avez besoin d'outils spéciaux pour construire le paquet à partir des sources en regardant le drapeau NeedsCompilation dans la description.


8. Le paquet est sur Github / Bitbucket/Gitorious

il peut avoir un dépôt sur Github/Bitbucket/Gitorious. Ces paquets nécessitent le paquet remotes à installer.

library(remotes)
install_github("packageauthor/foobarbaz")
install_bitbucket("packageauthor/foobarbaz")
install_gitorious("packageauthor/foobarbaz")

(comme avec installr , vous pouvez avoir besoin de install.packages("remotes") d'abord.)


9. Il n'y a pas de version source du paquet

bien que la version binaire de votre le package est disponible, la version de la source ne l'est pas. Vous pouvez désactiver ce contrôle en paramétrant

options(install.packages.check.source = "no")

comme décrit dans cette réponse ainsi par imanuelc et la section des détails de ?install.packages .


10. Le paquet est dans un dépôt non standard

votre paquet se trouve dans un dépôt non standard (par ex. Rbbg ). En supposant qu'il soit raisonnablement conforme aux normes CRAN, vous pouvez tout de même le télécharger en utilisant install.packages ; vous n'avez qu'à spécifier l'URL du dépôt.

install.packages("Rbbg", repos = "http://r.findata.org")

RHIPE d'un autre côté, n'est pas dans un dépôt de type CRAN et a son propre "instructions d'installation .

410
répondu Richie Cotton 2018-04-16 19:20:11
la source

dans le dernier R (3.2.3) il y a un bug, l'empêchant parfois de trouver le paquet correct. La solution est de configurer le dépôt manuellement:

install.packages("lubridate", dependencies=TRUE, repos='http://cran.rstudio.com/')

solution trouvée dans autre question

70
répondu Dmitry 2017-05-23 15:26:36
la source

Il semble y avoir un problème avec certaines versions de R et libcurl . J'ai eu le même problème sur Mac (R version 3.2.2) et Ubuntu (R version 3.0.2) et dans les deux cas il a été résolu simplement en exécutant ceci avant la commande install.packages 151970920"

options(download.file.method = "wget")

la solution a été suggérée par un ami, cependant, je n'ai pu la trouver dans aucun des forums, donc soumettre cette réponse pour d'autres.

22
répondu Saba 2016-07-22 13:52:11
la source

11. R (ou une autre dépendance) est périmé et vous ne voulez pas le mettre à jour.

Avertissement ce n'est pas exactement la meilleure pratique.

  • Téléchargez la source du paquet.
  • naviguez vers le fichier DESCRIPTION .
  • supprimer la ligne offensante avec votre éditeur de texte par exemple

    Depends: R (>= 3.1.1)
    
  • installer à partir du local (c.-à-d. à partir du répertoire parent de DESCRIPTION ) p.ex.

    install.packages("foo", type="source", repos=NULL)
    
8
répondu dardisco 2015-06-01 05:36:31
la source

une chose qui m'est arrivée est que la version de R fournie par ma distribution linux (R version 3.0.2 fournie par Ubuntu 14.04) était trop ancienne pour la dernière version du paquet disponible sur CRAN (dans mon cas, plyr version 1.8.3 à partir d'aujourd'hui). La solution était d'utiliser le système d'empaquetage de ma distribution au lieu d'essayer d'installer à partir de R ( apt-get install r-cran-plyr m'a obtenu la version 1.8.1 de plyr ). Peut-être que j'aurais pu essayer de mettre à jour R en utilisant updateR() , mais j'ai peur cela interférerait avec le gestionnaire de paquets de ma distribution.

8
répondu bli 2015-07-08 16:20:03
la source

cela m'a épargné beaucoup de temps pour déboguer ce qui ne va pas. Dans de nombreux cas sont juste des miroirs périmés. Cette fonction peut installer plusieurs paquets avec leurs dépendances en utilisant https://cran.rstudio.com/ :

packages <- function(pkg){
    new.pkg <- pkg[!(pkg %in% installed.packages()[, "Package"])]
    if (length(new.pkg))
        install.packages(new.pkg, dependencies = TRUE, repos='https://cran.rstudio.com/')
    sapply(pkg, require, character.only = TRUE)
}

packages(c("foo", "bar", "baz"))
8
répondu Tombart 2017-03-06 23:12:17
la source

C'est ce que je pouvais enfin faire pour installer le paquet psych dans R-3.4.1 quand j'ai reçu le même avertissement

1: googlé pour ce paquet.

2:téléchargé manuellement avec du goudron.GZ extension

3: Choisissez l'option "Package Archive File (.zip.;tar.gz)" pour installer les paquets dans R

4:consulté localement à l'endroit où il a été téléchargé et cliqué installer

Vous pouvez obtenir un attention: les dépendances "xyz" ne sont pas disponibles pour le paquet, puis installez d'abord celles du dépôt, puis faites les étapes 3-4 .

4
répondu Biboswan 2017-08-06 14:51:08
la source

j'ai corrigé cette erreur sur Ubuntu en suivant attentivement les instructions pour installer R .

  1. ajout de deb http://cran.utstat.utoronto.ca/bin/linux/ubuntu trusty/ à mon /etc/apt/sources.fichier de liste
  2. Running sudo apt-get update
  3. Running sudo apt-get install r-base-dev

pour l'étape 1, vous pouvez choisir n'importe quel miroir de téléchargement CRAN à la place de mon miroir de L'Université de Toronto si vous le souhaitez.

3
répondu AlexG 2016-08-29 10:32:50
la source

j'ai eu le même problème (sur Linux) qui pouvait être résolu en modifiant les paramètres proxy. Si vous êtes derrière un serveur proxy, vérifiez la configuration en utilisant Sys.getenv("http_proxy") dans R. Dans mon ~/.Renviron j'ai eu les lignes suivantes (de https://support.rstudio.com/hc/en-us/articles/200488488-Configuring-R-to-Use-an-HTTP-or-HTTPS-Proxy ) à l'origine du problème:

http_proxy=https://proxy.dom.com:port
http_proxy_user=user:passwd

Changer

http_proxy="http://user:[email protected]:port"

résolu le problème. Vous pouvez faire la même chose pour https .

ce n'était pas la première fois que je lisais" le paquet xxx n'est pas disponible pour la version r-x-y-z"...

HTH

3
répondu nachti 2017-04-14 14:00:56
la source

j'ai fait l'erreur d'oublier de mettre repos=NULL lors de l'installation du paquet R à partir du code source. Dans ce cas, le message d'erreur est légèrement trompeur: package 'foobarbaz' is not available (for R version x.y.z)

le problème n'était pas la version de R, c'était le paramètre repos . J'ai fait install.packages('path/to/source/code/of/foobarbaz', type='source', repos=NULL) qui a fonctionné pour moi dans cette occasion.

J'espère que ça aidera quelqu'un.

2
répondu damjan 2018-08-12 20:04:10
la source

ça marche presque toujours pour moi quand j'utilise bioconducteur comme source et puis j'invoque le biocLite. Exemple:

source("https://bioconductor.org/biocLite.R")
biocLite("preprocessCore")
1
répondu BioProgram 2016-01-04 18:18:23
la source

comme mentionné ici , cela peut se produire lorsque vous avez deux versions de R installées sur votre ordinateur. Désinstallez le plus ancien, puis réessayez l'installation de votre paquet! Il a bien fonctionné pour moi.

1
répondu Clément F 2017-03-07 23:10:33
la source

Cette solution peut casser R Mais voici une solution plus facile qui fonctionne 99% du temps.

Vous devez faire est de simplement:

installer.packages ('package-name', repos= ' ) http://cran.us.r-project.org ')

comme l'a mentionné l'auteur au-dessus de ici

1
répondu PaladiN 2018-09-07 06:38:32
la source

autre ajout mineur, en essayant de tester pour une ancienne version R en utilisant l'image docker rocker/r-ver:3.1.0

  1. le paramètre par défaut repos est MRAN , ce qui ne permet pas d'obtenir de nombreux paquets.
  2. cette version de R n'a pas https , donc, par exemple: install.packages("knitr", repos = "https://cran.rstudio.com") semble fonctionner.
0
répondu Jack Wasey 2016-12-30 20:49:20
la source

j'ai rencontré le même problème lors de l'installation du paquet"sentiment". Commencé à Chercher et essayé de nombreuses commandes. Enfin, le paquet installé en utilisant la commande suivante:

install_url("http://cran.r-project.org/src/contrib/Archive/sentiment/sentiment_0.2.tar.gz")
-3
répondu aditya harbola 2015-12-03 14:30:58
la source

Autres questions sur r installation r-faq package repository